Author Topic: Installation  (Read 1354 times)

johnno56

  • Guest
Installation
« on: July 12, 2018, 11:28:49 pm »
I have downloaded and installed EGSL 1.6.0 without issue.

The IDE executed without issue. The interpreter, however, is another ball of wax.

I am running with the 64bit version of Linux Mint 18.1 (LUA 5.2 installed)

I copy and paste the "3D Stars" example (from this site - http://retrogamecoding.org/board/index.php?topic=30.0) into the IDE and when "execute script" button is clicked, nothing. No problem. I then decided to run it from a 'Terminal' using the ./egsl filename command and was presented with the following error message.

"./egsl: error while loading shared libraries: libSDL_gfx.so.13: cannot open shared object file: No such file or directory"

I do not know how to fix this... Since the publication of '3D Stars', in 2012, my OS has been automatically updated several times. My system is currently using libSDL_gfx.so.15

I know there is a command to enter a symbolic link but I need to know, before I potentially muck things up, as to how to do this 'correctly'.  Any assistance would be greatly appreciated.

If you need more info, just ask and if I can, I will let you know.

Thank you.

J

johnno56

  • Guest
Re: Installation
« Reply #1 on: July 13, 2018, 03:23:34 pm »
I was reading somewhere on this forum that EGSL is no longer being developed? If that is the case then can some please close this thread?

J

Cybermonkey

  • Administrator
  • *****
  • Posts: 0
Re: Installation
« Reply #2 on: July 13, 2018, 06:25:28 pm »
Yep, it isn't developed anymore. Seems in the meantime compatibility with newer Linux distributions is broken.

Cybermonkey

  • Administrator
  • *****
  • Posts: 0
Re: Installation
« Reply #3 on: September 08, 2018, 09:30:55 pm »
I just learned that EGSL is still working correctly on Haiku. So for anyone who's interested ...